Asp.Net News
Free Tech Magazines
Asp.Net Web Hosting
Suggest Us
Link to Us
Feeds Subscription
Questions & Answers
Tips & Tricks
 Datalist pager - It thinks it works but it doesn't adjust page size
Posted by Charlie Childs on  4/10/2010 9:09:31 AM Category: ADO.NET
Add to my favorites
Email to friend
I am a newbie who has followed a tutorial re a datalist pager wriiten by moderater1 at this site. The tutrial expects its students to be more experienced than me. ie it expects students to know what goes at the top of the code behind page ( "imports" in VB / "using" in C# ) and I think it expects students to adjust Visual Studio property / events without any guidence. I think I have placed all the "using" ( assemblers? ) correctly most of the adjustments in VWD user interface properties window but it appears that I am missing one vital ingredient.

My actual pager control ( see here - ) is behaving just as it would if it was working properly but it is not adjusting the amount of records on the page. It's a little slow ( attached to many db records ) so below I say what it actually does do :

It knows how many records are in the db field because it diplays the right amount of page numbers.and it adjusts the amount of page numbers according to the page size options in its dropdown list.

It highlights which page it believes it is on once a user chooses a page.

It knows which page it is supposed to be displaying - ie "previous" and "next" buttons react properly re clicking on last link or first link.

I think the problem is in the properties events section of VWD user interface or is another very basic mistake because I am as sure as I can be that my code is the same as the lessons which gets excellent response reviews from very many other people who have used it.

I am asking this question in the hope that there may be a simple answer available or so that I can get indication of what could be wrong in order to be able to post a properly described and concise question along my code.

Lesson I followed is here - - and its working example is here -

Please can anyone help?

Post Your Reply Post New Question

 Viewer's Reply
Answered By Charlie Childs on 4/12/2010 5:40:03 PM
SORTED - IT WORKS !! After much brain sapping - a combination of simple errors - me newbie - please forgive.
Related Solution for this Issue
Answered By Moderator1 on 4/23/2010 10:28:14 AM
Hi all,

Related solution found at below links,
Post Your Reply If you still have problem, post it again under this reply for better response.

Sponsored by
Run Your Own Web Server Using Linux & Apache - Free 191 Page Preview
When Good HTML Goes Bad: How You Can Protect Your Web Applications
Windows 8: 50 Questions and Answers You Need to Make a Decision (Normally $9.95)